Putting a bug in your ear

Bug's Ear

Being secure is your only way to ensure your Google rankings.

Last year Google announced that it would rank “secure” sites over “non-secure” sites. Put aside the whole PHP version 7 issue, from 2016 which, I hope you’ve done by now. Google has announced that they would lower the ranking of those sites without the “HTTPS:” designation coming in this month.

We’ve all heard the stories of security breaches and the “internet gods” have deemed this the next necessary step.

Therefore, there is more than one level of “secure” that exists. It depends on what data you collect from your site. For any site with a search or contact form you need the lowest level of security (which cost less), for those who actually take credit cards and other really private data, you’ll need the tighter (more expensive) security license.

If you are on our server (and you and don’t want a “vanity” socket) we can get this service set up without the yearly renewal fees from the licenser but, your pages will not be your own unique https://yoursite.com/whatever , they will be the sever-name dot whatever.

We can have this rocking for you in couple of days to. Let us know when we need to proceed with your security and we’ll get you SECURE!

Don’t let this keep bugging you! We got your back!